Problem with Date fields

Nov 27, 2012 at 3:47 PM

When I try to batch edit date fields, I get the error:

Unfortunately there was an error updating the items with the provided values, a system administrator can use the message below to check upon this error, please provide them with it.
String was not recognized as a valid DateTime.

This is in the UK but i';ve tried puttingthem in in US format mm/dd/yyyy and it still fails silently and doesn't update. Any ideas?

Thanks for the great tool otherwise!


Nov 27, 2012 at 7:35 PM

It might be the locale settings that you have on your browser, but I am not sure. I have a 1033 site that works fine with updating datetimefields, could you check your region settings on your machine / browser and post them? That way we can eliminate those.

Nov 28, 2012 at 12:15 PM

In terms of browser settings, are you referring to my IE settings for languages? This is set to English United Kingdom. In terms of Regional settings for the SharePoint sites this isn't working on, they are set to English (United Kingdom) as well using 24 hour time. Time zone is set to UTC (Greenwich Mean time). Calendar is Gregorian.

Feb 5, 2013 at 5:20 PM
Anyone got any advice on this issue as it is still a major problem which stops us using the app properly because it doesn't work with dates. Thanks in advance.
Feb 5, 2013 at 5:29 PM
I've tried it on a test site with really weird results.

With the region settings set to United Kingdom for the SharePoint site,I set the date fields on 2 documents to 12th February 2013 using the date picker, then hit save. They display in the column as 02/12/2013 (wrong in the UK)

If I then switch locales in SharePoint to United States, the previously set dates are now displayed correctly as (12/02/2013) but making a new set of batch edits will still show up as 12/02/2013!!! Really need to get this fixed.
Nov 12, 2013 at 5:10 AM
Edited Nov 12, 2013 at 10:56 PM
robinthakur wrote:
Really need to get this fixed.

Couldn't agree more.... any word on when this will be fixed?
Nov 13, 2013 at 10:11 AM
Should be fixed in last release
Marked as answer by appieschot on 11/13/2013 at 2:11 AM